re = /catch *\((\w+)\) *{[^}]+(\1)(\.stack)[^}]+}/m
str = 'try {
print(new Function (astatement)())
} catch (e) { print(e.stack) }
try {
print(new Function (bstatement)())
} catch (exception) { print(exception.stack) }
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end