using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"catch *\((\w+)\) *{[^}]+(\1)(\.stack)[^}]+}";
string input = @"try {
print(new Function (astatement)())
} catch (e) { print(e.stack) }
try {
print(new Function (bstatement)())
} catch (exception) { print(exception.stack) }
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}