import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "catch *\\((\\w+)\\) *\\{[^\\}]+(\\1)(\\.stack)[^\\}]+\\}";
final String string = "try {\n"
+ " print(new Function (astatement)())\n"
+ "} catch (e) { print(e.stack) }\n\n"
+ "try {\n"
+ " print(new Function (bstatement)())\n"
+ "} catch (exception) { print(exception.stack) }\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}