package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\bXander\b.*$`)
var str = `Set of Xanderous
Set of hiXander
Set of hiXanderous
Xander Tray of 6
Tray of 6 pieces Xander
Set of 6 Xander pieces
Another test string`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}