re = /^.*\bXander\b.*$/m
str = 'Set of Xanderous
Set of hiXander
Set of hiXanderous
Xander Tray of 6
Tray of 6 pieces Xander
Set of 6 Xander pieces
Another test string'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end