// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\bXander\b.*$").unwrap();
let string = "Set of Xanderous
Set of hiXander
Set of hiXanderous
Xander Tray of 6
Tray of 6 pieces Xander
Set of 6 Xander pieces
Another test string";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}