$re = '/^.*\bXander\b.*$/m';
$str = 'Set of Xanderous
Set of hiXander
Set of hiXanderous
Xander Tray of 6
Tray of 6 pieces Xander
Set of 6 Xander pieces
Another test string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);