import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\bXander\\b.*$";
final String string = "Set of Xanderous\n"
+ "Set of hiXander\n"
+ "Set of hiXanderous\n"
+ "Xander Tray of 6\n"
+ "Tray of 6 pieces Xander\n"
+ "Set of 6 Xander pieces\n"
+ "Another test string";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}