using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"№(?P<lot>\d+).*дубина магических канделябров.*-(?P<cost>.*)\(";
string input = @"лот №102: ⚔ топор бесстрашных канделябров ( 2) - 21 (начальная ставка)
лот №103: ⚔ дубина магических канделябров ( 2) - 26 (начальная ставка)
лот №104: ⚔ булава непобедимых побед ( 3) - 111 (начальная ставка";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}