$re = '/№(?P<lot>\d+).*дубина магических канделябров.*-(?P<cost>.*)\(/m';
$str = 'лот №102: ⚔ топор бесстрашных канделябров ( 2) - 21 (начальная ставка)
лот №103: ⚔ дубина магических канделябров ( 2) - 26 (начальная ставка)
лот №104: ⚔ булава непобедимых побед ( 3) - 111 (начальная ставка';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);