package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)№(?P<lot>\d+).*дубина магических канделябров.*-(?P<cost>.*)\(`)
var str = `лот №102: ⚔ топор бесстрашных канделябров ( 2) - 21 (начальная ставка)
лот №103: ⚔ дубина магических канделябров ( 2) - 26 (начальная ставка)
лот №104: ⚔ булава непобедимых побед ( 3) - 111 (начальная ставка`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}