use strict;
my $str = 'лот №102: ⚔ топор бесстрашных канделябров ( 2) - 21 (начальная ставка)
лот №103: ⚔ дубина магических канделябров ( 2) - 26 (начальная ставка)
лот №104: ⚔ булава непобедимых побед ( 3) - 111 (начальная ставка';
my $regex = qr/№(?P<lot>\d+).*дубина магических канделябров.*-(?P<cost>.*)\(/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}