#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(?:[^0-9.][^.]*)?$"
Local $sString = "test.string.with.dots.but.ending.alpha=0.25.rda" & @CRLF & _
"test.string.with.dots.but.without.ending.alpha=0.25" & @CRLF & _
"test.string.with.dots.but.ending.alpha=0.25."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)