re = /\.(?:[^0-9.][^.]*)?$/m
str = 'test.string.with.dots.but.ending.alpha=0.25.rda
test.string.with.dots.but.without.ending.alpha=0.25
test.string.with.dots.but.ending.alpha=0.25.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result