const regex = /\.(?:[^0-9.][^.]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?:[^0-9.][^.]*)?$', 'gm')
const str = `test.string.with.dots.but.ending.alpha=0.25.rda
test.string.with.dots.but.without.ending.alpha=0.25
test.string.with.dots.but.ending.alpha=0.25.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);