// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\.(?:[^0-9.][^.]*)?$").unwrap();
let string = "test.string.with.dots.but.ending.alpha=0.25.rda
test.string.with.dots.but.without.ending.alpha=0.25
test.string.with.dots.but.ending.alpha=0.25.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}