use strict;
my $str = 'test.string.with.dots.but.ending.alpha=0.25.rda
test.string.with.dots.but.without.ending.alpha=0.25
test.string.with.dots.but.ending.alpha=0.25.';
my $regex = qr/\.(?:[^0-9.][^.]*)?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";