$re = '/\.(?:[^0-9.][^.]*)?$/m';
$str = 'test.string.with.dots.but.ending.alpha=0.25.rda
test.string.with.dots.but.without.ending.alpha=0.25
test.string.with.dots.but.ending.alpha=0.25.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;