#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<field>(?![^\s&]*&)\S+(?: (?!\([^)]*\)|[^&\s]*&)\S+)*)\s*(?P<col>&[a-zA-Z_]+)?\s*(?P<pos>\(.*?\))?$"
Local $sString = "name &cp_name (,10)" & @CRLF & _
"name &test" & @CRLF & _
"name (test)" & @CRLF & _
"name" & @CRLF & _
"print_name (name, 10)" & @CRLF & _
"print_name test (name, 10)" & @CRLF & _
"print_name t&est (name, 10)" & @CRLF & _
"pr&int_nam()e test (name, 10)" & @CRLF & _
" print_name test (name, 10)" & @CRLF & _
"&cp_name" & @CRLF & _
"(name, 10) (name, 10)" & @CRLF & _
"(name, 10) &cp_name" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")