import re
regex = re.compile(r"^(?P<field>(?![^\s&]*&)\S+(?: (?!\([^)]*\)|[^&\s]*&)\S+)*)\s*(?P<col>&[a-zA-Z_]+)?\s*(?P<pos>\(.*?\))?$", flags=re.MULTILINE)
test_str = ("name &cp_name (,10)\n"
"name &test\n"
"name (test)\n"
"name\n"
"print_name (name, 10)\n"
"print_name test (name, 10)\n"
"print_name t&est (name, 10)\n"
"pr&int_nam()e test (name, 10)\n"
" print_name test (name, 10)\n"
"&cp_name\n"
"(name, 10) (name, 10)\n"
"(name, 10) &cp_name\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")