$re = '/^(?P<field>(?![^\s&]*&)\S+(?: (?!\([^)]*\)|[^&\s]*&)\S+)*)\s*(?P<col>&[a-zA-Z_]+)?\s*(?P<pos>\(.*?\))?$/m';
$str = 'name &cp_name (,10)
name &test
name (test)
name
print_name (name, 10)
print_name test (name, 10)
print_name t&est (name, 10)
pr&int_nam()e test (name, 10)
print_name test (name, 10)
&cp_name
(name, 10) (name, 10)
(name, 10) &cp_name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);