use strict;
my $str = 'name &cp_name (,10)
name &test
name (test)
name
print_name (name, 10)
print_name test (name, 10)
print_name t&est (name, 10)
pr&int_nam()e test (name, 10)
print_name test (name, 10)
&cp_name
(name, 10) (name, 10)
(name, 10) &cp_name
';
my $regex = qr/^(?P<field>(?![^\s&]*&)\S+(?: (?!\([^)]*\)|[^&\s]*&)\S+)*)\s*(?P<col>&[a-zA-Z_]+)?\s*(?P<pos>\(.*?\))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}