using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<field>(?![^\s&]*&)\S+(?: (?!\([^)]*\)|[^&\s]*&)\S+)*)\s*(?P<col>&[a-zA-Z_]+)?\s*(?P<pos>\(.*?\))?$";
string input = @"name &cp_name (,10)
name &test
name (test)
name
print_name (name, 10)
print_name test (name, 10)
print_name t&est (name, 10)
pr&int_nam()e test (name, 10)
print_name test (name, 10)
&cp_name
(name, 10) (name, 10)
(name, 10) &cp_name
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}