import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<field>(?![^\\s&]*&)\\S+(?: (?!\\([^)]*\\)|[^&\\s]*&)\\S+)*)\\s*(?P<col>&[a-zA-Z_]+)?\\s*(?P<pos>\\(.*?\\))?$";
final String string = "name &cp_name (,10)\n"
+ "name &test\n"
+ "name (test)\n"
+ "name\n"
+ "print_name (name, 10)\n"
+ "print_name test (name, 10)\n"
+ "print_name t&est (name, 10)\n"
+ "pr&int_nam()e test (name, 10)\n"
+ " print_name test (name, 10)\n"
+ "&cp_name\n"
+ "(name, 10) (name, 10)\n"
+ "(name, 10) &cp_name\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}