#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5}(?:,[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5})*$"
Local $sString = "12aeabc11bba,662baea1abc2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12-ae-ab-c1-1b-ba,66-2b-ae-a1-ab-c2" & @CRLF & _
"" & @CRLF & _
"12:ae:ab:c1:1b:ba,66:2b:ae:a1:ab:c2" & @CRLF & _
"" & @CRLF & _
"12aeabc11bba,662baea1abc2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")