import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5}(?:,[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5})*$";
final String string = "12aeabc11bba,662baea1abc2\n\n\n"
+ "12-ae-ab-c1-1b-ba,66-2b-ae-a1-ab-c2\n\n"
+ "12:ae:ab:c1:1b:ba,66:2b:ae:a1:ab:c2\n\n"
+ "12aeabc11bba,662baea1abc2\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}