import re
regex = re.compile(r"^[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5}(?:,[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5})*$", flags=re.MULTILINE)
test_str = ("12aeabc11bba,662baea1abc2\n\n\n"
"12-ae-ab-c1-1b-ba,66-2b-ae-a1-ab-c2\n\n"
"12:ae:ab:c1:1b:ba,66:2b:ae:a1:ab:c2\n\n"
"12aeabc11bba,662baea1abc2\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")