using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5}(?:,[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5})*$";
string input = @"12aeabc11bba,662baea1abc2
12-ae-ab-c1-1b-ba,66-2b-ae-a1-ab-c2
12:ae:ab:c1:1b:ba,66:2b:ae:a1:ab:c2
12aeabc11bba,662baea1abc2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}