re = /^[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5}(?:,[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5})*$/m
str = '12aeabc11bba,662baea1abc2
12-ae-ab-c1-1b-ba,66-2b-ae-a1-ab-c2
12:ae:ab:c1:1b:ba,66:2b:ae:a1:ab:c2
12aeabc11bba,662baea1abc2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end