use strict;
my $str = '12aeabc11bba,662baea1abc2
12-ae-ab-c1-1b-ba,66-2b-ae-a1-ab-c2
12:ae:ab:c1:1b:ba,66:2b:ae:a1:ab:c2
12aeabc11bba,662baea1abc2
';
my $regex = qr/^[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5}(?:,[a-fA-F0-9]{2}(?:[:-]?[a-fA-F0-9]{2}){5})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}