#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]\d{2}(?:\.\d{1,2}|\d{0,2})$"
Local $sString = "D99" & @CRLF & _
"M00.0" & @CRLF & _
"M01.6" & @CRLF & _
"J98.3" & @CRLF & _
"T05.0" & @CRLF & _
"M96.81" & @CRLF & _
"D68.20" & @CRLF & _
"D3412" & @CRLF & _
"D34." & @CRLF & _
"" & @CRLF & _
"9D.0" & @CRLF & _
"6G" & @CRLF & _
"7H." & @CRLF & _
"M96.811" & @CRLF & _
"J234.82" & @CRLF & _
"G687.1" & @CRLF & _
"GU87.11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")