const regex = /^[A-Z]\d{2}(?:\.\d{1,2}|\d{0,2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]\\d{2}(?:\\.\\d{1,2}|\\d{0,2})$', 'gm')
const str = `D99
M00.0
M01.6
J98.3
T05.0
M96.81
D68.20
D3412
D34.
9D.0
6G
7H.
M96.811
J234.82
G687.1
GU87.11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}