// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]\d{2}(?:\.\d{1,2}|\d{0,2})$").unwrap();
let string = "D99
M00.0
M01.6
J98.3
T05.0
M96.81
D68.20
D3412
D34.
9D.0
6G
7H.
M96.811
J234.82
G687.1
GU87.11";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}