import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]\\d{2}(?:\\.\\d{1,2}|\\d{0,2})$";
final String string = "D99\n"
+ "M00.0\n"
+ "M01.6\n"
+ "J98.3\n"
+ "T05.0\n"
+ "M96.81\n"
+ "D68.20\n"
+ "D3412\n"
+ "D34.\n\n"
+ "9D.0\n"
+ "6G\n"
+ "7H.\n"
+ "M96.811\n"
+ "J234.82\n"
+ "G687.1\n"
+ "GU87.11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}