use strict;
my $str = 'D99
M00.0
M01.6
J98.3
T05.0
M96.81
D68.20
D3412
D34.
9D.0
6G
7H.
M96.811
J234.82
G687.1
GU87.11';
my $regex = qr/^[A-Z]\d{2}(?:\.\d{1,2}|\d{0,2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}