using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]\d{2}(?:\.\d{1,2}|\d{0,2})$";
string input = @"D99
M00.0
M01.6
J98.3
T05.0
M96.81
D68.20
D3412
D34.
9D.0
6G
7H.
M96.811
J234.82
G687.1
GU87.11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}