# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z0-9]+)\s+([\w\-\.]+)\s([a-z0-9]+)\s([0-9]+)/LOCAL_INTERFACE = \1\nNEIGHBOR = \2\nNEIGHBOR_INTERFACE = \3/gmi;t' <<< "Et1 lab-fr-sw01.test.local Ethernet24 120"