import Foundation
let pattern = #"([a-z0-9]+)\s+([\w\-\.]+)\s([a-z0-9]+)\s([0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"Et1 lab-fr-sw01.test.local Ethernet24 120"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"LOCAL_INTERFACE = \1\nNEIGHBOR = \2\nNEIGHBOR_INTERFACE = \3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)