#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)([a-z0-9]+)\s+([\w\-\.]+)\s([a-z0-9]+)\s([0-9]+)"
Local $sString = "Et1 lab-fr-sw01.test.local Ethernet24 120"
Local $sSubst = "LOCAL_INTERFACE = \1\nNEIGHBOR = \2\nNEIGHBOR_INTERFACE = \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)