use strict;
my $str = 'Et1 lab-fr-sw01.test.local Ethernet24 120';
my $regex = qr/([a-z0-9]+)\s+([\w\-\.]+)\s([a-z0-9]+)\s([0-9]+)/mip;
my $subst = 'LOCAL_INTERFACE = \\1\\nNEIGHBOR = \\2\\nNEIGHBOR_INTERFACE = \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";