// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)([a-z0-9]+)\s+([\w\-\.]+)\s([a-z0-9]+)\s([0-9]+)").unwrap();
let string = "Et1 lab-fr-sw01.test.local Ethernet24 120";
let substitution = "LOCAL_INTERFACE = \\1\\nNEIGHBOR = \\2\\nNEIGHBOR_INTERFACE = \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}