re = /([a-z0-9]+)\s+([\w\-\.]+)\s([a-z0-9]+)\s([0-9]+)/mi
str = 'Et1 lab-fr-sw01.test.local Ethernet24 120'
subst = 'LOCAL_INTERFACE = \\1\\nNEIGHBOR = \\2\\nNEIGHBOR_INTERFACE = \\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result