#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?![\/]).*?title.*?>"
Local $sString = "Given this:" & @CRLF & _
" <Bla bla ="nametitle">Yada yade</title>" & @CRLF & _
"" & @CRLF & _
"I want:" & @CRLF & _
" <Bla bla ="nametitle">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<Bla bla ="nametitle">Yada yade</title>" & @CRLF & _
"<title>Yada yada</title>" & @CRLF & _
"<my title="slash/slash">Yada/yade</title>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Answering this question:" & @CRLF & _
"https://stackoverflow.com/questions/23723067/limiting-a-character-after-a-wildcard-in-regex-to-its-first-occurrence" & @CRLF & _
"" & @CRLF & _
"This was tried:" & @CRLF & _
" <(.*?)(title)(.*?)>" & @CRLF & _
"" & @CRLF & _
"My ideas is to use this:" & @CRLF & _
" <(?![\/]).*?title.*?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")