re = /<(?![\/]).*?title.*?>/m
str = 'Given this:
<Bla bla ="nametitle">Yada yade</title>
I want:
<Bla bla ="nametitle">
<Bla bla ="nametitle">Yada yade</title>
<title>Yada yada</title>
<my title="slash/slash">Yada/yade</title>
Answering this question:
https://stackoverflow.com/questions/23723067/limiting-a-character-after-a-wildcard-in-regex-to-its-first-occurrence
This was tried:
<(.*?)(title)(.*?)>
My ideas is to use this:
<(?![\\/]).*?title.*?>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end