import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?![\\/]).*?title.*?>";
final String string = "Given this:\n"
+ " <Bla bla =\"nametitle\">Yada yade</title>\n\n"
+ "I want:\n"
+ " <Bla bla =\"nametitle\">\n\n\n"
+ "<Bla bla =\"nametitle\">Yada yade</title>\n"
+ "<title>Yada yada</title>\n"
+ "<my title=\"slash/slash\">Yada/yade</title>\n\n\n"
+ "Answering this question:\n"
+ "https://stackoverflow.com/questions/23723067/limiting-a-character-after-a-wildcard-in-regex-to-its-first-occurrence\n\n"
+ "This was tried:\n"
+ " <(.*?)(title)(.*?)>\n\n"
+ "My ideas is to use this:\n"
+ " <(?![\\/]).*?title.*?>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}