import Foundation
let pattern = #"<(?![\/]).*?title.*?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Given this:
<Bla bla ="nametitle">Yada yade</title>
I want:
<Bla bla ="nametitle">
<Bla bla ="nametitle">Yada yade</title>
<title>Yada yada</title>
<my title="slash/slash">Yada/yade</title>
Answering this question:
https://stackoverflow.com/questions/23723067/limiting-a-character-after-a-wildcard-in-regex-to-its-first-occurrence
This was tried:
<(.*?)(title)(.*?)>
My ideas is to use this:
<(?![\/]).*?title.*?>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)