import re
regex = re.compile(r"<(?![\/]).*?title.*?>", flags=re.MULTILINE)
test_str = ("Given this:\n"
" <Bla bla =\"nametitle\">Yada yade</title>\n\n"
"I want:\n"
" <Bla bla =\"nametitle\">\n\n\n"
"<Bla bla =\"nametitle\">Yada yade</title>\n"
"<title>Yada yada</title>\n"
"<my title=\"slash/slash\">Yada/yade</title>\n\n\n"
"Answering this question:\n"
"https://stackoverflow.com/questions/23723067/limiting-a-character-after-a-wildcard-in-regex-to-its-first-occurrence\n\n"
"This was tried:\n"
" <(.*?)(title)(.*?)>\n\n"
"My ideas is to use this:\n"
" <(?![\\/]).*?title.*?>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")