use strict;
my $str = 'Given this:
<Bla bla ="nametitle">Yada yade</title>
I want:
<Bla bla ="nametitle">
<Bla bla ="nametitle">Yada yade</title>
<title>Yada yada</title>
<my title="slash/slash">Yada/yade</title>
Answering this question:
https://stackoverflow.com/questions/23723067/limiting-a-character-after-a-wildcard-in-regex-to-its-first-occurrence
This was tried:
<(.*?)(title)(.*?)>
My ideas is to use this:
<(?![\\/]).*?title.*?>';
my $regex = qr/<(?![\/]).*?title.*?>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}