#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!(<IMG.+src=\"))http:\/\/i[0-9]{3}\.photobucket\.com\/albums\/[^\/]+\/[^\/]+\/[^\/\"]+(?=\".*/>)"
Local $sString = "<img src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />" & @CRLF & _
"<IMG src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" foo="bar"/>" & @CRLF & _
"<img alt="text" src="http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />" & @CRLF & _
"<img alt="text" src="http://i077.photobucket.com/albums/myalbum/Emi998/mypicture.jpg" />"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")