using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(<IMG.+src=\""))http:\/\/i[0-9]{3}\.photobucket\.com\/albums\/[^\/]+\/[^\/]+\/[^\/\""]+(?=\"".*/>)";
string input = @"<img src=""http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg"" />
<IMG src=""http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg"" foo=""bar""/>
<img alt=""text"" src=""http://i774.photobucket.com/albums/myalbum/Emi998/mypicture.jpg"" />
<img alt=""text"" src=""http://i077.photobucket.com/albums/myalbum/Emi998/mypicture.jpg"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}